Telephone Lines are down
Incident Report for DTAC - Network & Service Status
Resolved
All toll-free service which were affecting DigAlert have been restored.
DigAlert hold times are high, use Web Update Express, or DigAlert Express to avoid waiting.
Posted over 2 years ago. Oct 04, 2016 - 08:38 PDT
Identified
The telephone company is experiencing technical difficulties with their toll-free service which is affecting DigAlert. Please use our online services such as DigAlert Express, and Web Update Express for your ticket needs in the meantime.
Posted over 2 years ago. Oct 04, 2016 - 07:44 PDT
This incident affected: Contact Center Telephone Lines.