Web Update is currently down
Incident Report for DTAC - Network & Service Status
Resolved
Web Update And Update Express are currently working!
Posted over 2 years ago. Jan 03, 2017 - 12:26 PST
Investigating
For the time being, Web Update and Web Update Express are currently not functioning. This also includes updating through our apps. To update your tickets or request remarks please contact 811.
Posted over 2 years ago. Jan 03, 2017 - 08:18 PST