811 down temporarily
Incident Report for DTAC - Network & Service Status
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 12:41 PDT
Monitoring
Phone lines are operational, but we are currently monitoring the issue.
Posted Nov 03, 2021 - 09:11 PDT
This incident affected: Contact Center Telephone Lines.